[필수 문제] 팩토리얼
2021. 2. 13. 15:48ㆍ코딩 테스트/필수 문제
1. 문제
N 팩토리얼 (N!)은 1부터 N까지의 곱으로 정의된다.
예를 들어
- 3! = 1 x 2 x 3 = 6
- 4! = 1 x 2 x 3 x 4 = 24 이다.
N이 주어질 때, N!을 계산하는 프로그램을 작성하시오.
입력
첫 번째 줄에 숫자 N이 주어진다. ( 1 ≤ N ≤ 10 )
출력
첫째 줄에 N!을 출력한다.
예제 입력
4
예제 출력
24
2. 풀이
import java.io.*;
public class Main {
private static final BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
private static final BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
public static void main(String[] args) throws IOException {
int n = Integer.parseInt(br.readLine());
bw.write(factorial(n) + "");
br.close();
bw.flush();
bw.close();
}
private static int factorial(int n) {
if(n == 1) return 1;
return n * factorial(n-1);
}
}
728x90
'코딩 테스트 > 필수 문제' 카테고리의 다른 글
[필수 문제] division (0) | 2021.02.13 |
---|---|
[필수 문제] 순열 구하기 (0) | 2021.02.13 |
[필수 문제] 큰 자릿수 뺄셈 (0) | 2021.02.13 |
[필수 문제] streetree (0) | 2021.02.13 |