[필수 문제] 단지 번호 붙이기
2021. 2. 15. 11:19ㆍ코딩 테스트/필수 문제
1. 문제
<그림 1>과 같이 정사각형 모양의 지도가 있다. 1은 집이 있는 곳을, 0은 집이 없는 곳을 나타낸다. 철수는 이 지도를 가지고 연결된 집들의 모임인 단지를 정의하고, 단지에 번호를 붙이려 한다. 여기서 연결되었다는 것은 어떤 집이 좌우, 혹은 아래위로 다른 집이 있는 경우를 말한다. 대각선상에 집이 있는 경우는 연결된 것이 아니다. <그림 2>는 <그림 1>을 단지별로 번호를 붙인 것이다. 지도를 입력하여 단지수를 출력하고, 각 단지에 속하는 집의 수를 오름차순으로 정렬하여 출력하는 프로그램을 작성하시오.
입력
첫 번째 줄에는 지도의 크기 N(정사각형이므로 가로와 세로의 크기는 같으며 5≤N≤25)이 입력되고, 그 다음 N줄에는 각각 N개의 자료(0혹은 1)가 입력된다.
출력
첫 번째 줄에는 총 단지수를 출력하시오. 그리고 각 단지내 집의 수를 오름차순으로 정렬하여 한 줄에 하나씩 출력하시오.
예제 입력
7
0110100
0110101
1110101
0000111
0100000
0111110
0111000
예제 출력
3
7
8
9
2. 풀이
이 문제는 DFS, BFS 2 가지로 접근이 가능하다. 우선 DFS의 경우, 배열을 돌면서 1을 만나는 지점을 기준으로 상하좌우를 돌며 1인 곳을 순회하는 방법이다.
import java.io.*;
import java.util.ArrayList;
import java.util.Collections;
public class Main {
private static final BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
private static final BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
private static int n;
private static int[][] arr;
private static boolean[][] isVisited;
private static int[] dy = {-1, 1, 0, 0};
private static int[] dx = {0, 0, -1, 1};
private static int count;
private static ArrayList<Integer> result;
public static void main(String[] args) throws IOException {
n = Integer.parseInt(br.readLine());
arr = new int[n][n];
isVisited = new boolean[n][n];
for(int i = 0; i < n; i++) {
String[] str = br.readLine().split("");
for(int j = 0; j < n; j++) {
arr[i][j] = Integer.parseInt(str[j]);
}
}
result = new ArrayList<>();
for(int i = 0; i < n; i++) {
for(int j = 0; j < n; j++) {
count = 0;
if(arr[i][j] == 1 && !isVisited[i][j]) dfs(i, j);
if(count > 0) result.add(count);
}
}
bw.write(result.size() + "\n"); // 단지 수
Collections.sort(result); // 정렬
for(int i = 0; i < result.size(); i++) {
bw.write(result.get(i) + "\n"); // 집의 수
}
br.close();
bw.flush();
bw.close();
}
private static void dfs(int i, int j) {
isVisited[i][j] = true;
count++;
for(int k = 0; k < 4; k++) {
int y = i + dy[k];
int x = j + dx[k];
if(y >= 0 && y < n && x >= 0 && x < n) {
// 배열의 범위를 벗어나지 않고, 상하좌우에 1이 있으며 방문하지 않은 곳일 경우
if(arr[y][x] == 1 && !isVisited[y][x]) dfs(y, x);
}
}
}
}
BFS는 다음과 같다.
import java.io.*;
import java.util.ArrayList;
import java.util.Collections;
import java.util.LinkedList;
import java.util.Queue;
public class Main {
private static final BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
private static final BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
private static int n;
private static int[][] arr;
private static boolean[][] isVisited;
private static int[] dy = {-1, 1, 0, 0};
private static int[] dx = {0, 0, -1, 1};
private static int count;
private static ArrayList<Integer> result;
public static void main(String[] args) throws IOException {
n = Integer.parseInt(br.readLine());
arr = new int[n][n];
isVisited = new boolean[n][n];
for(int i = 0; i < n; i++) {
String[] str = br.readLine().split("");
for(int j = 0; j < n; j++) {
arr[i][j] = Integer.parseInt(str[j]);
}
}
result = new ArrayList<>();
for(int i = 0; i < n; i++) {
for(int j = 0; j < n; j++) {
count = 0;
if(arr[i][j] == 1 && !isVisited[i][j]) bfs(i, j);
if(count > 0) result.add(count);
}
}
bw.write(result.size() + "\n"); // 단지 수
Collections.sort(result); // 정렬
for(int i = 0; i < result.size(); i++) {
bw.write(result.get(i) + "\n"); // 집의 수
}
br.close();
bw.flush();
bw.close();
}
private static void bfs(int i, int j) {
Queue<int[]> queue = new LinkedList<>();
queue.add(new int[] {i, j});
isVisited[i][j] = true;
count++;
while(!queue.isEmpty()) {
int[] w = queue.poll();
for(int k = 0; k < 4; k++) {
int y = w[0] + dy[k];
int x = w[1] + dx[k];
if(y >= 0 && y < n && x >= 0 && x < n) {
if(arr[y][x] == 1 && !isVisited[y][x]) {
queue.add(new int[] {y, x});
isVisited[y][x] = true;
count++;
}
}
}
}
}
}
728x90
'코딩 테스트 > 필수 문제' 카테고리의 다른 글
[필수 문제] 전염병 (0) | 2021.02.15 |
---|---|
[필수 문제] 깊이우선탐색과 너비우선탐색 (0) | 2021.02.15 |
[필수 문제] 웜 바이러스 (0) | 2021.02.15 |
[필수 문제] 이분 그래프 판별 (0) | 2021.02.15 |